Kategori

Excel
Excel Formül Örnekleri

Excel yazılarımı Excel’de formül oluşturma ve çalıştırma örnekleri ile devam etmek istiyorum. Excel kullanıyorsanız ki bir de çok sık kullanıyorsanız o zaman Excel’in formül fonksiyonunu da bilmeniz gerekmektedir. Formülsüz Excel çok işinize yaramayacaktır. Excel’i çok sık kullanıyor da bu zamana kadar formül yazma işini yapmadıysanız, bu yazıdan sonra aklınızdaki Excel profili komple değişecektir. Çünkü Excel’in asıl gücünü formüllerle göreceksiniz. Şimdi yavaş yavaş formül nasıl yazılır ne işe yarar öğrenmeye başlayalım.

Örnek tablomuz aşağıdaki gibi olacak. Siz de bu tabloyu Excel’de oluşturunuz.

A B C D E F
1 Adı ve Soyadı Durumu ARA SINAV Final G. Ort. Sonuç
2 Ramazan DEMİREL Devamlı 70 75 73
3 Semih AKGÜN Devamlı 80 45 0
4 Hayati DEMİR Devamsız 65 50 58
5 A. Arif AKDOĞAN Devamlı 55 0 0
6 Recep ŞENTÜRK Devamlı 90 75 83
7 Ufuk BAYRAK Devamsız 75 35 0
8 Murat GÜNEŞ Devamlı 50 80 65
9 Nursel ALTAN Devamlı 40 0 0
10 Cemil CANSIZ Devamsız 60 50 55
11 Ali BULUT Devamlı 80 95 88
12 Yahya SONAKALAN Devamlı 40 75 58
13 Tülay ŞAHİN Devamsız 45 75 60
14 Esra ÖZDEMİR Devamlı 70 45 0
15 Adem URAL Devamsız 80 50 65
16 M. Serkan  Devamlı 65 90 78
17 Ergin YELEKÇİ Devamlı 55 75 65
18 Metin ÇULHA Devamsız 90 35 0
19 Recep YEŞİLBAŞ Devamlı 75 80 78
20 Abdullah DULKAN Devamlı 50 50 50
21 Resul GÜLDÜ Devamlı 40 50 45
22 A. Fuat KAVAK Devamsız 60 0 0
23 Eray KURU Devamlı 80 75 78

İlk olarak tabloyu inceleyelim. Tablomuzda A, B, C, D, E, F sütunları; 1, 2, 3, 4 ……. 23 kadar satır var. 

  1. satırımızda tablo başlıkları bulunmaktadır. Yani verileri işlerken 1. satırı işin içine sokmayacağız anlamına geliyor. 

Tablo okumada zayıf olan arkadaşlarımız için;

A sütunu 2. satırdaki hücrenin içeriği “Ramazan DEMİREL” dir. 

F sütunu 19. satırdaki hücrenin içeriği “GEÇER” dir. 

Formül işinde ön önemli şey satır ve sütun değeriyle veriyi ne olduğunu anlayabilmemiz gerekmektedir. Yani Excel tablomuzda her hücrenin bir koordinatı vardır ki bu koordinat satır ve sütün numarası ile oluşur.

Şimdi en basitinden başlayarak C sütununun 24. satırına o sütundaki sayıları toplatalım. Yapacağımız işlem sonucu C2 ile C23 arasındaki hücrelerin değerlerini toplatmış olacağız.

Burada C2 dediğim —-> C sütunu 2. satır anlamına gelmektedir. Yazımın bundan sonraki bölümde hücreleri bu şekilde adlandıracağım. 

Şimdi C24 hücresine =TOPLA(C2:C23) yazalım. Excel otomatik olarak bu hücre aralığını toplayacaktır ve sonuç olarak C24 hücresine 1415 yazacaktır.

  • Her formül = işareti ile başlar
  • = işaretini yazıp formülü yazmaya başladığımız an Excel bünyesindeki formülleri ekrana getirir ve işleminizi kolaylaştırır. Birkaç örnekten sonra daha iyi anlayacaksınız.

Şimdi C25 hücresine =ORTALAMA(C2:C23) yazalım ve bu hücrelerdeki sayıların ortalamasını bulduralım. Sonuç 64,13 çıkacaktır.

C26 hücresine =ETOPLA(C2:C23;”>40″) yazalım. ETOPLA formülü 40’dan büyük sayıları toplayacaktır.

Şimdi biraz zorlaştıralım 

F2 hücresine =EĞER(VE(E2>=50;B2=”Devamlı”);”GEÇER”;”KALIR”) yazalım ve bu formülü irdeleyelim.

Bu komutta diyoruz ki eğer E2 hücresindeki değer 50’den büyük ve B2 hücresindeki değer de Devamlı ile bu hücreye GEÇER yaz değilse KALIR yaz.

Formülde VE kıstasını kullanmasaydık yani =EĞER((E2>=50);”GEÇER”;”KALIR”) sadece E2 hücresini kontrol ettirip bir sonuç ürettirmiş olacaktık.

Ya da bir kıstas daha ekleyebilir =EĞER(VE(VE(E2>=50;B2=”Devamlı”;D2>50);”GEÇER”;”KALIR”) işin içine final notunu da katabilirdik. Formülünüzü istediğiniz kadar geliştirebilirsiniz.

Yazdığımız formülü tüm hücrelerde çalıştırabilmek için, formül yazdığınız hücrenin sağ alt köşesinden tutup aşağıya doğru çekin. Yazıdğınız formül tüm hücrelere otomatik olarak uygulanacaktır.

E24 hücresine =MAK(E2:E24) yazalım. Mak formülü notlar arasındaki en büyük notu bulacak ve yazdıracaktır.

Excel’de sık kullanılan formüller ve örnekler

A B C
FORMÜL
ADI
Y A Z I L I Ş I Y A P T I Ğ I   İ Ş L E M
TOPLA =TOPLA(B2:B10) B2’den B10’a kadar olan hücrelerin değerlerini topla
=100+350+451 3 adet sabit sayıyı toplar
=A5+650 A5 hücresi(ndeki sayı) ile sabit bir sayıyı (650) toplar
=A5+B3+F4 3 Adet hücrenin içeriğini toplar
ÇARPMA =35*670000 2 Sabit rakamı çarpar
=A2*670000 A2 hücresi ile bir sabit rakamı çarpar
=A2*B3 A2 Hücresi ile B3 hücresini çarpar
ÇIKARTMA =155-85 İki sabit rakamın farkını alır
=155-A9 Bir sabit rakam ile A9 hücresinin farkını alır
=A2-C2 2 hücrenin farkını alır
BÖLME =32500000/325000 Bir sabit rakamı bir başka sabit rakama böler
=A5/325000 A5 hücresinin içeriğini bir sabit rakama böler
=A1/C4 A1 hücresini C4 hücresine böler
ORTALAMA =ORTALAMA(B2:B10) B2’den B10’a kadar olan hücrelerin ortalamasını alır
YÜZDE =A1*0,18 A1 hücresinin % 18’ini alır
=A1*0,26 A1 hücresinin % 26’sını alır
=A1*1,18 A1 Hücresinin % 118’ini (%18 fazlasını) bulur
=A1*1,26 A1 Hücresinin % 126’sını (%26 fazlasını) bulur
EN BÜYÜK =MAK(C2:C10) C2’den C10’a kadar hücrelerden en büyük olanının değerini yazar
EN KÜÇÜK =MİN(C2:C10) C2’den C10’a kadar hücrelerden en küçük olanının değerini yazar
EĞERSAY =EĞERSAY(B2:B10;”LİSE”) B2’den B10’a kadar olan hürelerden kaçında LİSE yazdığını bulur
BOŞLUKSAY =BOŞLUKSAY(B2:B10) B2’den B10’a kadar olan hürelerden kaçının boş olduğunu bulur
BAĞ_DEĞ_DOLU_SAY =BAĞ_DEĞ_DOLU_SAY(B2:B10) B2’den B10’a kadar olan hürelerden kaçının dolu olduğunu bulur
BİRLEŞTİR =BİRLEŞTİR(D9;F9) D9 hücresindeki metin ile F9 hücresindeki metni birleştirir.
UZUNLUK =UZUNLUK(D8) D8 hücresindeki metnin kaç karakterden oluştuğunu bulur
EĞER =EĞER(A3>2;”İYİ”;”KÖTÜ”) A3 hücresindeki sayı 2 den büyükse İYİ değilse KÖTÜ yazar
=EĞER(A3>=2;”İYİ”;”KÖTÜ”) A3 hücresindeki sayı 2 rakamı dahil ve 2 den büyükse İYİ değilse KÖTÜ yazar
=EĞER(B2>0;”KÂR”;”ZARAR”) B2 hücresinin değeri 0’dan büyükse KÂR değilse ZARAR yazar
=EĞER(B2>2;”GEÇTİ”;”KALDI”) B2 hücresinin değeri 2’den büyükse GEÇTİ değilse KALDI yazar
ROMEN =ROMEN(A1) A1 hücresindeki rakamı roma rakamına çevirir
BÜYÜKHARF =BÜYÜKHARF(A1) A1 hücresindeki metni büyük harflerle yazar
KÜÇÜKHARF =KÜÇÜKHARF(A1) A1 hücresindeki metni küçük harflerle yazar
KAÇINCI =KAÇINCI(“MEHMET”;D15:D19) D15 ile D19 hücresi arasında “MEHMET” in kaçıncı hücrede yer aldığını yaz
EBOŞSA =EBOŞSA(A2) A2 hücresi boşsa DOĞRU, doluysa YANLIŞ yaz
SATIRSAY =SATIRSAY(D5:D13) D5’ten D13’e kadar kaç satır bulunduğunu yaz
SÜTUNSAY =SÜTUNSAY(D12:H12) D12’den H12’ye kadar kaç sütun bulunduğunu yaz
ŞİMDİ =ŞİMDİ() Şu andaki tarihi ve saati gösterir
BUGÜN =BUGÜN() Bugünün tarihini verir
LİRA =LİRA(A1) A1 hücresindeki rakamı Türk parasına çevirir

Bu tablodan formüllere bakarak uygulayabilirsiniz. Ne kadar çok örnek yaparsanız o kadar çabuk öğrenirsiniz. 

Yorum Yap